Archive

Posts Tagged ‘Websphere’

IBM RAD 7.5 on Ubuntu Karmic 32 Bit

December 8th, 2009 No comments

IBM Rational Application Developer
Lets assume you were using ubuntu 9.04 jaunty and now you have upgraded your distribution to 9.10 karmic. Before i get into 9.10 version i had my RAD 7.5 installed and running. Then decided to upgrade my distro. I’ve read an article and futures of karmic distro, that says plenty of packages getting updated. After getting done with upgrade process i tried to run my RAD 7.5 , it was ok for the first time but there were plenty of errors on screen.

First of all when you upgrade your distro, the gcc++ package gets upgareded so libstdc++.so.5 file to libstdc++.so.6 .Unfortunately RAD 7.5 version looks for libstdc++.5.so file on your system. You have to download this file. Download it by using link below;

http://packages.debian.org/stable/base/libstdc++5

Then install this deb package (If you are running on another linux distro you have to place it just next to where your libstdc++.6.so file, you can use “locate libstdc++.so.6″ command to see where your file is). Then copy below bash script and paste it any of your text editor, save it as “run.sh”. From now on, you can use this script to run your RAD 7.5.

#!/bin/bash
export GTK_NATIVE_WINDOWS=1
/where/your/RADis &

After this process your problem should be gone. Have fun.

VN:F [1.9.22_1171]
Rating: 7.3/10 (4 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
Categories: HowTo Tags: , , , , ,